Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


Programs u need to run and play LoL

12
Comment below rating threshold, click here to show it.

Tiutlivel

Junior Member

11-11-2010

On official site u can see that the most important is "Verify that you also have the latest update to Microsoft .NET Framework." and link to microsoft net framework 4.0. That's not quite true (i mean with Microsoft .NET Framework 4.0).

To play LoL u have to get:
1. Windows service pack 3
2. the latest update to Adobe air (from adobe site)
3.updated Microsoft .NET Framework 1.1
4. updated Microsoft .NET Framework 3.5
5. updated Microsoft .NET Framework 4.0
6. Direx 9.0c
7. plus everything what u can already read on official site

U need that three version of Microsoft .NET Framework because of unique MNF Liberties and u don't need 2.0 version because everything whats in 2.0 is in 3.5.

I posted that because maybe it will help to others who have launcher errors problem. If Administration think that post is not understandable because of mine horrible English feel free to delete (or rewrite) that post. Everything what u see upside is about playing on Windows XP. I don't know how it looks on Vista, Windows 7 etc.


Comment below rating threshold, click here to show it.

DimitrijeS

Senior Member

11-12-2010

I had a very frustrating problem just because i trusted this:

Quote:
Riot:
On official site u can see that the most important is "Verify that you also have the latest update to Microsoft .NET Framework." and link to microsoft net framework 4.0.


Since i had every piece of software that has anything to do with LoL updated to the latest i spent an hour or two asking people for help about a bug I've been experiencing until i decided to install 3.5 "just for fun", which solved the problem -.-


Comment below rating threshold, click here to show it.

KiLlSh0oT

Junior Member

04-03-2011

why dont they make league of legends playble with net framework 1.0 and abobe air 1.0


Comment below rating threshold, click here to show it.

SirRFI

Senior Wrenchman

04-04-2011

These programs are required:

  • Internet Explorer 8
  • Adobe Air
  • DirectX9 (latest!)
  • .net Framework 3.5
Not sure if Pando Media Booster is needed to run the game.


Comment below rating threshold, click here to show it.

Ryciune

Recruiter

05-22-2011

I spend all they from 11 hour to 23:10 hour to fix my problem with launcher coz it didn't load and I just now saw this post!!! And now I know what I need is just a stupid .net frame work 3.5 and launcher fixed !!! :@


Comment below rating threshold, click here to show it.

Renas

Recruiter

06-22-2011

Why ins't this thread stickied?


Comment below rating threshold, click here to show it.

LittleZoe

Senior Member

06-22-2011

Why is IE required?! O.o


Comment below rating threshold, click here to show it.

Tw4tb4g

Recruiter

06-22-2011

Pando isn't needed I uninstalled after installing the game.


Comment below rating threshold, click here to show it.

MrWrong

Junior Member

12-28-2011

why i need explorer 8 ?


Comment below rating threshold, click here to show it.

victore007

Junior Member

03-05-2012

Is windows SP3 requise???


12