Unusual high ping

Comment below rating threshold, click here to show it.

OMGWTFIPWN

This user has referred a friend to League of Legends, click for more information

Senior Member

18-02-2012

Hello!

I don't know what's wrong, but for 2 days now I have unusually high ping. I use 3 mobile broadband connection in the UK, it's not the best, but I was usually playing at ~120 ms, now it's 300-500. I checked everything, but nothing has changed in my configuration, software setting or internet connection(exactly the same results from speedtest.net as before), my firewall hasn't suddenly started blocking LoL either.

Perhaps it's some in-game setting or something to do with the patch...?

Can anybody tell me how to fix this?


Comment below rating threshold, click here to show it.

Britin

Member

18-02-2012

Same problem, different isp


Comment below rating threshold, click here to show it.

OMGWTFIPWN

This user has referred a friend to League of Legends, click for more information

Senior Member

18-02-2012

So, doesn't anybody know how to solve this problem?
Please, it's so annoying, and there is no obvious reason for it.


Comment below rating threshold, click here to show it.

OMGWTFIPWN

This user has referred a friend to League of Legends, click for more information

Senior Member

18-02-2012

Gonna check if I have the same lag on EUNE, got an account there as well.


Comment below rating threshold, click here to show it.

OMGWTFIPWN

This user has referred a friend to League of Legends, click for more information

Senior Member

18-02-2012

Same issue on EUNE too, but it can't be my ISP, as there is no change there, I still get the absolutely same speedtest.net results, and nothing else loads slower/has higher ping either.


Comment below rating threshold, click here to show it.

MJKMJK

Member

18-02-2012

got the same exact problem. started after ziggs patch. tried everything. must be something riot did.
but i just ordered a 20mbit internet so hopefully it will be better then. but if someone knows how to solve it before then please say


Comment below rating threshold, click here to show it.

Britin

Member

18-02-2012

Just played a bot game and disconnected 4 times. Every time my ping jumped to 500 and the game was soaking up so much of my Bandwidth I wasn't able to load any other web pages without closing LoL completely. Servers are messed up big time.

I am a Sky Broadband customer.


Comment below rating threshold, click here to show it.

OMGWTFIPWN

This user has referred a friend to League of Legends, click for more information

Senior Member

18-02-2012

I tried playing during the night - it improved my ping, brought it back to normal, but there were tons of other people with lags(6 people in a single game) and pings higher than 300, so it is indeed the servers.
Something must have gone wrong after the patch.


Comment below rating threshold, click here to show it.

wetdreamx

Junior Member

18-02-2012

Have the same problem, got uni net and went home and used virgin broadband and both have the same issue, no idea what to do.

Think it could be a hardware issue with the patch not working with some drivers duno.


Comment below rating threshold, click here to show it.

OMGWTFIPWN

This user has referred a friend to League of Legends, click for more information

Senior Member

18-02-2012

Where are you guys from? Perhaps the problem is somehow location based.
I am playing from Edinburgh, UK, using 3(Three) mobile broadband.

Using Dell laptop, Windows 7 Home Premium(32bit), running Comodo Internet Security Premium with latest definitions.