Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


Tutorial: LoL in Wine (Linux)

Comment below rating threshold, click here to show it.

DeemR

Junior Member

08-21-2010

Hi,
I installed Ubuntu 10.04 yesterday and I want to install LoL. So I downloaded wine 1.1.42 with this commend: [CODE]apt-get install wine[/CODE]. Then I downloaded winetricks and patch1 and patch 2 for wine. And there my problem starts ... I tried to install winetricks this way:
[CODE]sudo sh winetricks adobeair vcrun2005 ie6 d3dx9 [/CODE]but it doesn't work. I got:
[CODE]wine: /home/rafal/.wine is not owned by you
------------------------------------------------------
You (root) don't own /home/rafal/.wine. Don't run winetricks as another user!
------------------------------------------------------[/CODE]
It doesn't matter where is this winetricks file. If I run it from /usr/lib32/wine/ I got same error.

Could someone help me with this?


Comment below rating threshold, click here to show it.

J4zz

Junior Member

08-21-2010

Quote:
DeemR:
[CODE]sudo sh winetricks adobeair vcrun2005 ie6 d3dx9 [/CODE]but it doesn't work. I got:[CODE]wine: /home/rafal/.wine is not owned by you
------------------------------------------------------
You (root) don't own /home/rafal/.wine. Don't run winetricks as another user!
------------------------------------------------------[/CODE]It doesn't matter where is this winetricks file. If I run it from /usr/lib32/wine/ I got same error.
As "Don't run winetricks as another user!" suggests, don't execute winetricks as root. Set execution permissions with [CODE]chmod u+x winetricks[/CODE] and execute winetricks without sudo.


Comment below rating threshold, click here to show it.

DeemR

Junior Member

08-21-2010

Ok done. I sucessful installed all this lib. Then I installed LoL but when I'm running launcher I have to agree with rules and then I got this:
http://yfrog.com/bgprogramerrorp (http://yfrog.com/bgprogramerrorp)


I think that the reason for this is that the patch is not installed becouse I don't know how ...


Comment below rating threshold, click here to show it.

AbgrazIbermorgen

Junior Member

08-21-2010

Hey, i got it running under ubuntu 10.04 with a patched wine v1.3.0 but the game isn't displayed correctly and i got ~ 3-4FPS...

but i must admit that i have a intel mobile 945something and i don't know if i would have more FPS under windows :P

I attached two screenshots with the graphic errors.

please RIOT give us a native linux client!


Comment below rating threshold, click here to show it.

DeemR

Junior Member

08-22-2010

http://www.cedega.com/gamesdb/games/view.html?game_id=5297 Cedega doesn't work too -.-

I downloaded wine 1.3 and still nothing :/ Same error. I think I have to install Windows.


Comment below rating threshold, click here to show it.

Gabbajoe

Junior Member

08-23-2010

Hihow,

for me Lol under linux works now including ingame chat and ingame shop but in team fight i have low fps from 9fpd ~15fps on a normal line creaping if have 50fps ~60fps.

My wine setup:
wine 1.30 with the patches of this topic and winetricks.
compile parameters:
./configure
make depend
make CFLAGS="-O2"
sudo make install

I setup wine as windows 2000 with any other settings the ingame chat case in a lol crash.
graphic card: Nvidia 8800GT with Nvidias Drivers Version 256.44
Dist: ubuntu 10.04


Tweaks in Game.cfg (/home/nkeller/.wine/drive_c/Programme/League of Legends/Game/DATA/CFG/defaults)
all shows set to 0 and all glow entries set to 0.

Ingame is set all to low and for frames i set fix to 60fps if i set to stable i got only 3fps ~15fps.

Best Regards,

Nils


Comment below rating threshold, click here to show it.

Gabbajoe

Junior Member

08-23-2010

Quote:
DeemR:
http://www.cedega.com/gamesdb/games/view.html?game_id=5297 Cedega doesn't work too -.-

I downloaded wine 1.3 and still nothing :/ Same error. I think I have to install Windows.


Hey DeemR

what says the output:
glxinfo | grep -i render?

have you installed with wine tricks abode air, ie6 and vc++2005 redist?(not as root user)
what did you setup in winecfg for audio and windows version?
For me i compiles wine 1.3.0 with pulse audio support because i got trouble with alsa and the pulse audio wrapper for wine.

Best Regards,

Nils


Comment below rating threshold, click here to show it.

Gabbajoe

Junior Member

08-23-2010

Hi,

tested it now with wine 1.3.1 same settings and if got more frames in team figt now 15fps ~29fps.

Best regards,

Nils


Comment below rating threshold, click here to show it.

DeemR

Junior Member

08-23-2010

Good news ^ I have source for wine 1.3.1. But could you tell me how install this two patch? I think they are important They have to be only in this source files and configure will add it?

edit: Ok I installed patches



Quote:
Gabbajoe:
Hey DeemR
what says the output:
glxinfo | grep -i render?

[CODE]
direct rendering: Yes
OpenGL renderer string: GeForce 9600 GT/PCI/SSE2
GL_NV_depth_buffer_float, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_NV_vertex_program3, GL_NVX_conditional_render, GL_SGIS_generate_mipmap, [/CODE]

Quote:
Gabbajoe:
Hey DeemR
have you installed with wine tricks abode air, ie6 and vc++2005 redist?(not as root user)
what did you setup in winecfg for audio and windows version?
For me i compiles wine 1.3.0 with pulse audio support because i got trouble with alsa and the pulse audio wrapper for wine.

Best Regards,

Nils

I install all of this lib from first post in this topic.
And windows version is XP and audio I have ALSA.

I will try to install it again later


Comment below rating threshold, click here to show it.

Gabbajoe

Junior Member

08-24-2010

Quote:
DeemR:
Good news ^ I have source for wine 1.3.1. But could you tell me how install this two patch? I think they are important They have to be only in this source files and configure will add it?

edit: Ok I installed patches




[CODE]
direct rendering: Yes
OpenGL renderer string: GeForce 9600 GT/PCI/SSE2
GL_NV_depth_buffer_float, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_NV_vertex_program3, GL_NVX_conditional_render, GL_SGIS_generate_mipmap, [/CODE]


I install all of this lib from first post in this topic.
And windows version is XP and audio I have ALSA.

I will try to install it again later


Hi DeemR,

to get ingame chat working you need to set windows version windows 2000 with any other versions the game crashes.
I cross the fingers that this will work for you

Best regards,

Nils