Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


Chat: "^" inserted with every key stroke

1
Comment below rating threshold, click here to show it.

Dalhai

Senior Member

02-18-2015

Hi there,

I started having an annoying bug when I finally got my new keyboard.
Apparently, league gets an additional key event for my "^" key, whenever I press any other key.
While this does not influence the outcome of the game in any way, I am basically chat restricted for no reason. I have only seen one other guy with the same problem and apparently, he did not have the same keyboard as I did (more information about my setup below). Then again, the guy was drunk, so that's not a trustworthy source.

Example

"Hello there!" becomes "^Hê^l^lô^^t^hê^rê^!"

Specs

Keyboard: Corsair K70 Vengeance
OS: Windows 7 SP1 (UEFI, if of interest)
Mouse: Asus ROG Eagle Eye
Mainboard: ASUS Sabertooth Z77 (LGA1155)
Graphics: ASUS Nvidia GeForce GTX 970 STRIX
Processor: Intel Core i7-2600K @ 3.40GHz
RAM: Kingston 32GB Dual Channel DDR3

What I've tried so far

  • Doing a clean re install of League of Legends
  • Update the keyboard Firmware and Drivers to the current version
  • Remove all keyboard entities in the Device Manager (both Interfaces & Keyboard entities)
  • Switch the K70 for a brand new K70
  • Deactivate windows lock of the K70
  • Grab all keyboard events myself, both in a GLFW3/OpenGL as well as a Direct3D application, no doubles, no occurrences of "^".

Obviously, nothing has worked so far and there do not seem all too many people with the same problem.

Additional Information

This bug does not occur anywhere else. Not in other games, not in office applications, nowhere.
The bug vanished for a short time, after the clean reinstall. It worked flawlessly for ~10 Minutes into the first game, then the bug reappeared and never vanished since. Also note that I am using a fresh, clean windows install.

This post is my last resort, there really isn't much out there that would help me :|
Help is appreciated!


Comment below rating threshold, click here to show it.

Raykable

Junior Member

02-21-2015

Odd glitch, but you're not alone: http://youtu.be/0rxJI6SHolE?t=17m15s
Try informing the support, they might answer you better than us.


1