Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


UBUNTU CONNECTIVITY ISSUE SOLVE !REAL!

Comment below rating threshold, click here to show it.

RazorFighter90

Junior Member

01-12-2015

If you have everything done according tutorials. This will work for you on Ubuntu.


ANSWER AND SOLUTION PROVIDED BY METAPH
I DON'T TAKE ANY CREDITS FOR HIS GENIUS!




Press Ctrl+Alt+T
In the opened terminal type: sudo su
Your password (it won't be showing, but system will catch your characters)
In the same terminal, after you logged in as root@. Type in
echo 0 > /proc/sys/net/ipv4/tcp_timestamps


If it works for you, tell name of your OS and version, so I can add this to list. Apparently this need to apply every system restart.


Verified to work on these Linux systems:
- Ubuntu 14.04 LTS.
- Arch


Comment below rating threshold, click here to show it.

Metaph

Recruiter

01-12-2015

Thanks a lot for the credit man!
If you want to add mine i'm on ArchLinux

You can do it automatically every boot by editing /etc/sysctl.conf (For distros using systemd you may need to create /etc/sysctl.d/99-sysctl.conf)
Adding the line

Quote:
net.ipv4.tcp_timestamps = 0

should do the trick


Comment below rating threshold, click here to show it.

RazorFighter90

Junior Member

01-12-2015

Quote:
Metaph:
Thanks a lot for the credit man!

What do you thank for? Without you this wouldn't even run!


Comment below rating threshold, click here to show it.

simonthechipmunk

Junior Member

01-15-2015

Thanks a lot for this. I was going mad trying to resolve this issue. My honest respect for finding the cause with almost no useful information (the error message and logs given by the launcher were just no indication)

I have a few questions though:

1. Does turning off tcp_timestamping on the client side have any major downsides for tcp traffic on my machine?
(any explanations i found were merely server related)

2. Where does this issue originate from? Connection problems started around last weekend and persisted after the downtime (euw) on monday. So is this the result of Riot tweaking their server's timing parameters or is it related to the 3.13.0-44.73 kernel update that was also rolled out the same day?


Comment below rating threshold, click here to show it.

cloelie

Junior Member

01-15-2015

It's works!!!!


MANY THANKS FOR YOUR HELP, YOU ARE THE BEST ;-)

ENJOYE!!!!!


Comment below rating threshold, click here to show it.

Space Darkness

Member

01-15-2015

Quote:
Metaph:
Thanks a lot for the credit man!
If you want to add mine i'm on ArchLinux

You can do it automatically every boot by editing /etc/sysctl.conf (For distros using systemd you may need to create /etc/sysctl.d/99-sysctl.conf)
Adding the line

should do the trick


How can I do it on Ubuntu?


Comment below rating threshold, click here to show it.

makhla

Junior Member

01-15-2015

@simonthechipmunk

I am by no means a networking specialist, but here goes what i experience when i turn the tcp timestamps OFF.
The most glaring thing i noticed is trying to watch/listen to any kind of streaming video/audio (youtube, twitch, vimeo, soundcloud etc.) is not enjoyable anymore, even on low bitrates.

to your 2nd question. this is a stab in the dark. i did not (and do not intend to) wireshark my networking while playing league.

The problem seems to occur after your username/pw has been succesfully validated. worth noting that this instance is not affected by tcp timestamp settings.

The client then tries to logon to the pvp.net service. At this particular step the problem occurs.
This instance of the whole login procedure seems to refuse timestamped TCP packages.
Judging by wine debug logs there are three attempts to comminucate with that instance by the client / your pc.
Visually you will see the wobbly air-thingy on your screen, and once the third attempt fails, a blue error window will occur "Connection Failure : Unable to Connect to the PVP.net server ..."

I think in one of the recent DNS failure/connection error-threads there was a fellow summoner who said something along the lines of, that this paricular problem may be related to configuring of server-side settings. That would imply that something on the side of the pvp.net-service seems to be the culprit for this particular problem. This is a speculative.

So unless someone officially (aka. Riot) deems it necessary to provide any sort of explanation on this all we can do is speculate.


Comment below rating threshold, click here to show it.

simonthechipmunk

Junior Member

01-15-2015

@makhla

Thanks for your reply.

I didn't experience any problems with streams until now, but considering the tcp timestamp is also affecting RTT determinatiaon, this could very likely affect time dependent applications with a high data rate. Good point there.

Booting into an older Kernel doesn't help btw. (that was a really small chance anyway).

Quote:

The problem seems to occur after your username/pw has been succesfully validated. worth noting that this instance is not affected by tcp timestamp settings.


Exactly. The authentification is handled by the login server and after validation, the communication is directed to pvp.net server. It seems only this particular server is affected, for whatever reason.

Just for the record: Is anyone around here playing on other servers than euw and if so: Did you experience the same problems or is it only our beloved eu server again ?


Comment below rating threshold, click here to show it.

Pustekuchen24

Junior Member

01-16-2015

Wow, it works. Thanks a lot


Comment below rating threshold, click here to show it.

JackDestroyer

Senior Member

01-16-2015

It works! Linux Mint 17.1 (Rebecca)

Thank you.