cannot login due to certificate error after 20/5 maintenance

12345 ... 7
Comment below rating threshold, click here to show it.

Rhapsodyronin

Junior Member

20-05-2011

This occurred to me the first time I tried to log in after the emergency maintenance earlier, and has occurred to me ever since.

In the login screen after I type my password, I get this windows popup:

Quote:
This page requires a secure connection which ensures server authentication. The Certificate Issuer for this site is unknown. Do you wish to proceed?

Yes/No/View Certificate/More Info
Regardless of what I choose (choosing "View Certificate" will allow you to import the certificate, then continue, if you hit Yes you simply continue) I get the following pop up 4 times

Quote:
Revocation information for this security certificate for this site is not available. Do you want to proceed?

Yes/No/View Certificate
Again, selecting to view the certificate and importing it does not help, what follows up next is

Connection Failure: Unable to connect to PVP. net server.

tried:
checking cmos battery and bios time
updating windows (windows xp sp3) and windows date/time
tried installing the root certificates in question from DigiCert site to the Trusted Root Authorities Store since according to Windows, this is where there were supposed to be (got a security risk warning in the process)
Nothing worked. I don't have IE installed; I run Firefox 4. If it helps, I've installed nothing since before the emergency maintenance earlier today, and the game ran normally before that.

I'm currently re-installing LOL but I'm not too optimistic about it.

EDIT: http://n4.netalyzr.icsi.berkeley.edu...799f-47f2-adf0

SOLUTION UPDATE:
Go to Internet Explorer, open Internet Options->Advanced Tab->Security->untick "Check for server certificate revocation"->Restart Internet Explorer.
Go here https://www.digicert.com/digicert-root-certificates.htm and download the certificates. It is necessary to do this through IE.
This seems to work for almost everyone. Thx for the help guys.


Comment below rating threshold, click here to show it.

Randarin

Junior Member

20-05-2011

I have same problem...


Comment below rating threshold, click here to show it.

Nauri

This user has referred a friend to League of Legends, click for more information

Junior Member

20-05-2011

I too have this problem :/


Comment below rating threshold, click here to show it.

rokita

Junior Member

20-05-2011

Same problem for me, system data correct. I changed my video card today but data is correct


Comment below rating threshold, click here to show it.

marac2803

This user has referred a friend to League of Legends, click for more information

Member

20-05-2011

Same problem here.


Comment below rating threshold, click here to show it.

perdik

Junior Member

20-05-2011

I also have the same prob.

Any answer for solving???


Comment below rating threshold, click here to show it.

Peji FTW

This user has referred a friend to League of Legends, click for more information

Junior Member

20-05-2011

I have the same problem... I even reinstaled the game twice but still it didnt worked. The only thing that changed is that when the message appeared again and i clicked yes the game seemed to start but it was nonresponsive and the messege i got then was something like "adobe air debuger encountered a problem...". Oh and after a few more tries i go back to the original error, when after i click yes it just closes the launcher.


Comment below rating threshold, click here to show it.

Rhapsodyronin

Junior Member

20-05-2011

I've run out of ideas, and I'm not a computer guru. It could be the issue is server based. They recently changed their certificate authority from Thawte to Digicert and maybe something got mixed up in the process.

Let's see how long this takes...


Comment below rating threshold, click here to show it.

affenmunkEY

Senior Member

20-05-2011

Hmm for some reason there isnt a big hoobah about it though need a resolution


Comment below rating threshold, click here to show it.

FMaki

Junior Member

20-05-2011

Thought I was the only one, but seems not.
Updated my drivers and reinstall LOL 25 minutes ago, but still don't wanna connect, problem's still here.
And yesterday everything was alright...


12345 ... 7