Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


High-end Graphics Card FPS Issues

Comment below rating threshold, click here to show it.

Kisara Tendo

Recruiter

03-28-2014

OS: Windows 7
GPU: Nvidia GTX 660

DxDiag.txt

Comment below rating threshold, click here to show it.

blacktk

Junior Member

03-28-2014

OS: windows 7
CPU: NVIDIA GeForce GTX 560M

DxDiag leo.txt

Comment below rating threshold, click here to show it.

Legalize VCP

Member

03-28-2014

OS: Windows Vista
GPU: Nvidia GTX 460

DxDiag.txt

Comment below rating threshold, click here to show it.

Nipple lnspector

Junior Member

03-28-2014

Windows 8.1
i7 36350qm
8gb ram
amd HD8870m 2gb

Getting stuck at 30fps

DxDiag.txt

Comment below rating threshold, click here to show it.

lel17

Junior Member

03-28-2014

OS:Windows 7 64 bit basic
Nvidia GT 540M

DxDiag.txt

Comment below rating threshold, click here to show it.

Tside oGnik

Junior Member

03-28-2014

OS: Windows 8.1 x64
GPU: NVIDIA GeForce GTX 460 OC

DxDiag.txt

Comment below rating threshold, click here to show it.

h4r

Junior Member

03-28-2014

OS: Windows XP Professional Service Pack 3
GPU: NVIDIA GeForce 7600 GT

DxDiag.txt

Comment below rating threshold, click here to show it.

GodMode00

Junior Member

03-29-2014

OS: Windows 8.1 x64
GPU: AMD Radeon Graphics 7480
intel core i7 3.4 ghz
Thank you

DxDiag.txt

Comment below rating threshold, click here to show it.

Å mithy

Senior Member

03-29-2014

Os: w7
Gpu: gtx 760 4gb edition


Comment below rating threshold, click here to show it.

c0ckring

Junior Member

03-29-2014

I'm running a GTX 650 Ti boost and I've had no end of problems after the last patch. At first I was getting 01fps at the start of the game, when buffs spawned and then randomly through out the game. I repaired my client last night and attempted to play again today only to get into a game and be stuck at 1 fps for 10 minutes.

Rito, PLZ.

OS: Win 8.1
GPU: GTX 650 Ti Boost

Edit: I brought Thief today and I have to say ive also had no end of framerate problems with that game. I've updated my graphics driver and even on low it lags. I tested some of my slightly older games and they all run fine on high. Not sure if thief is just bad or these things are linked but im sure its not my hardware.

DxDiag.txt