Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


High-end Graphics Card FPS Issues

Comment below rating threshold, click here to show it.

Riot dArtagnan

Player Support Specialist

03-26-2014

Hey Summoners,

We are aware that there are some of you out there who are experiencing drastic FPS drops from well over 100, down to around 15 to 30 when playing on a higher end card (typically a Nvidia 700 series or AMD 7xxx/8xxx/R9). We are currently looking into and investigating this issue, but we will need some help from you.

If you are experiencing this particular issue, make a post including your Operating System, your specific Graphics Card, and an attachment of your DxDiag.

We understand how frustrating this issue is and with all of your help in providing this information, we hope to resolve this as quickly as possible.


Comment below rating threshold, click here to show it.

Aramanser

Senior Member

03-27-2014

OS: Windows 7 Ultimate 64-Bit
GPU: Radeon R9 270X (2048MB Sapphire Vapor-X Aktiv PCIe 3.0 x16)

I have the feeling that LoL is not using the capability of the GPU at all...


EDIT(3rd May 2014):

Summoner's Rift(5v5):
In laning phase I just have 60-100 fps with my graphic card! :/
In teamfights/baronfights I can have less than 20/30 fps (that depends on champions...)!
The longer the game the less fps... more than 4 weeks and nothing changed -.-

P.S.
@Riot: Patch 4.2 messed up with the frames on many systems.
You should really check the Version differences/ changes there! I didn't change my Graphic Card driver or anything else on my system, the Problem is at your end Riot. You probably messed up with your Game code.


Comment below rating threshold, click here to show it.

Bzzaa

Junior Member

03-27-2014

OS: Win 7
GC: AMD Radeon HD 6950

DxDiag.txt

Comment below rating threshold, click here to show it.

hel1007

Junior Member

03-27-2014

OS: Windows 7 Ultimate Edition
GC: GTX 770 (Msi Twin Frozr)

Why don't you need r3dlogs too ?

There is a lot of errors when i open it. I took an another HD which has LoL installed. There is the same errors but when i play with an another PC on the same HD, there is no error.

My problem: The game start with 0-10FPS for 30s, then i run at 60FPS, when minions spawn i return to 20-30FPS.

DxDiag.txt

Comment below rating threshold, click here to show it.

The Evil Mind

Junior Member

03-27-2014

OS: Windows 7 Ultimate 64-bit (6.1, Build 7601)
GC: GTX 550 Ti

Edit:
This is my last game log,I carry game as Syndra,all game stable 60~ fps,but in lategame teamfight I had 20 fps and only cause of it i lose the game,what the hell is that? I am platinum V and my mmr right now is 1600?! (elo hell) , I can't win games with that fps,in platinum need to teamfight,I can't avoid it. Do something faster please,can't wait no longer.

Edit:
31:03:2014
Tell me at least, that you had at least some clues...
All would be happy to hear that you are working on this
And soon, after months of waiting, poor FPS remain in the past.
I do not believe in God, but I believe in you!
Amen!

Best regards,
Your Syndra...

P.S.
By the way, when Syndra is close to her spheres, noted that when the 3 or more spheres,Syndra starts to twitch (left to right, as if she was drunk), this error can be cured? I wrote in right place?


Comment below rating threshold, click here to show it.

SaDi LeaDer

Junior Member

03-27-2014

Processor Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
Video Card 1 Intel(R) HD Graphics Family
Video Card 2 Radeon (TM) HD 7690M XT
Memory 8.1 GB
Operating System Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit


Comment below rating threshold, click here to show it.

LevelRed

Recruiter

03-27-2014

OS: Windows 7
GC: Nvidia GTX 560 Ti (x2)

DxDiag.txt

Comment below rating threshold, click here to show it.

EtonMess

Member

03-27-2014

Windows 7.
Nvidia GTX 760.

DxDiag.txt

Comment below rating threshold, click here to show it.

Vapourman

Junior Member

03-27-2014

OS: Windows 8
CPU: Intel(R) core(TM) i7-4770 CPU @ 3.4GHz
GPU: GeForce GTX 760 (192-Bit)

DxDiag.txt

Comment below rating threshold, click here to show it.

Game0fThrowz

Senior Member

03-27-2014

Hi.

It' aint only High end cards.

W7 x64
NVIDIA GeForce GT 220

All these problems have been introduced since the latest patch. Prior to this the game worked just fine.

I've attached a red log form a game I "played" today...was unplayable...02 fps in the first 10-15 secs after spawning and 06-12-30-60 fps back and forth every few seconds. Normal FPS prior to the patch was around 70-90 on this computer for which I have attached the Direct X diagnostic files.

You need the redlogs from the players too, to see if they have similar issues like the ones I see in mine because I think the error is not cause by our cards but the game engine itself.


What you'll see are

Missing texture errors (a lot)
Mesh Errors
Can not open file errors
And a hella lot of these "Attachment asked for a velocity on an object that no longer exists!"

So I guess the game engine drops FPS trying to compensate for all this while also feeding live data to the server.