4.1 patch update failure

12345 ... 6
Comment below rating threshold, click here to show it.

RedPwn

Junior Member

14-01-2014

When i start updating the new patch there pops up a unknown error so it won't update. Has this happened to anyone else? if so, were you able to fix it? or are you still stuck on this "unknown error". Does anyone have a clue how to fix this?


Comment below rating threshold, click here to show it.

Hansiman

Wrenchman

14-01-2014

Greetings.

I highly doubt you are downloading patch 4.1, as that has not been released yet. This will be rolled out this night, but we're still a few hours away.

Go to your lol-installation folder. Locate, and delete, the following two sub-folders:

Riot Games\League of Legends\RADS\downloads
Riot Games\League of Legends\RADS\solutions

Once you restart the client, these folders will be recreated, and your problem should be solved.


Comment below rating threshold, click here to show it.

BULWAHR w

Junior Member

15-01-2014

Hi,

Well i have similar problem, maybe not identical but here is whats going on.

I was able to update to patch 4.1 (with problems). Had to restart client few times to finish patching.
Several files didnt want to update. Finally all worked out. I was able to open my client, go to queue and start a game.
Just when the picks and ban finished and window with skins was about to show..... client crashed. Got a bug splat.
After restarting client and trying to reconnect to already started game i got error and bug splat every time.
Im unable to play.

Error i get on pop up window is this:

C:\Riot Games\League of Legends\RADS\RiotRadsIO.dll is not designed to start at windows system or contains an error.

Im not running english version of my windows7 so its the best translation i could manage to do :-)

What is this that error?
Can anyone help?
I


Comment below rating threshold, click here to show it.

Screw the Moose

Member

15-01-2014

Hi BULWAHAR,

try running the repair client option before the login screen. It might solve your problem.


Comment below rating threshold, click here to show it.

abecedar

Junior Member

15-01-2014

Delleting thos folders worked for me!!!!


Comment below rating threshold, click here to show it.

atvasinajums

Junior Member

15-01-2014

Deleting folders is not working. Also changing region doesn't help, update just freezes on applying patches part

Edit: with 20th try, worked...


Comment below rating threshold, click here to show it.

Shila1

Member

15-01-2014

irritating downloads the patch and then gets stuck on applying patch try restart like 3 times and evert time i have to wait another 20 min for the patch to be redownloaded...


Comment below rating threshold, click here to show it.

i am weedbott

Junior Member

15-01-2014

Deleting folders is not working. Also changing region doesn't help, update just freezes on applying patches part

SAME FOR ME... and im starting to feel pretty annoyed.. so please fix NOW!! ******* RIOT!


Comment below rating threshold, click here to show it.

BULWAHR w

Junior Member

15-01-2014

Deleting folders or any files didnt work for me.

Repairing client however did. During the process i got some info with some other fails,
but since i can play (tested on custom game for now) i dont touch anything .

Thx for the help Moose, sometimes simplest things dont come to mind :-)


Comment below rating threshold, click here to show it.

atvasinajums

Junior Member

15-01-2014

Changed the region to NA and waited for who knows how long, but the update eventualy finished
Still that does not fix the problem

Re-downloaded on my region, everything works


12345 ... 6