Welcome to the Forum Archive!

Years of conversation fill a tonne of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out Boards to join in the latest League of Legends discussions.

GO TO BOARDS


How to change Language?

Comment below rating threshold, click here to show it.

SquaidsAlert

Junior Member

03-21-2011

Same problem, the solution given by the kind wrenchmen aint helping

What to do?


Comment below rating threshold, click here to show it.

Phulven

Junior Member

04-01-2011

Put en_US instead of whatever language string exists in these files:
\League of Legends\game\DATA\CFG\game.cfg
\League of Legends\air\locale.properties

Verify en_US in this file too:
\League of Legends\game\DATA\CFG\defaults\Game.cfg

Worked for me.


Comment below rating threshold, click here to show it.

Folkstormz

Junior Member

04-03-2011

For in game language (audio and text)

If you want the default language (which is US english) just delete this line in \League of Legends\game\DATA\CFG\game.cfg

"LanguageLocaleRegion=fr_FR"

If you want another language replace LanguageLocaleRegion=fr_FR by :

LanguageLocaleRegion=de_DE for german
LanguageLocaleRegion=es_ES for spanish
LanguageLocaleRegion=en_GB for gb english

for the luncher it's the same but the file is \League of Legends\air\locale.properties

locale=fr_FR


Comment below rating threshold, click here to show it.

Psyhicx

Junior Member

04-08-2011

Still French.... -.-


Comment below rating threshold, click here to show it.

SirRFI

Senior Wrenchman

04-09-2011

Try this then:




PART #0 - PROLOG: There is no English in the installer! What to do?

  • Choose any language and continue installing.
  • When the game is already installed, proceed reading next parts in this post.

PART #1: How to change Launcher's language:
  • Run regedit.exe (Windows+R and type regedit)
  • Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Riot Games\League of Legends
  • Click on "League of Legends" folder
  • On the right side click on "Language" and modify it to one of following:
    • If you desire English, set this to en
    • If you desire French, set this to fr
    • If you desire German, set this to de
    • If you desire Spanish, set this to es
    It should just look like this: [CODE]en[/CODE]
  • Press OK and close regedit.
  • Run launcher

PART #2: How to change PvP.net's (lobby) language:
  • Go to \Air\ folder in League of Legends' folder.
  • Open locale.properties file with notepad. In case it does not exist - create it. MAKE SURE THE EXTENSION IS .properties , NOT .txt
    • If you desire English, set this to locale=en_GB
    • If you desire French, set this to locale=fr_FR
    • If you desire German, set this to locale=de_DE
    • If you desire Spanish, set this to locale=es_ES
    It should just look like this: [CODE]locale=en_GB[/CODE]
  • Save and close the file.

PART #3: How to change League of Legends' (in-game) language:
  • Go to \Game\DATA\CFG\ folder in League of Legends' folder.
  • Open game.cfg file with notepad. In case it does not exist - create it. MAKE SURE THE EXTENSION IS .cfg , NOT .txt
  • Under [General] there should be line like this:
    [CODE]LanguageLocaleRegion=en_GB[/CODE]
    • If you desire English, set this to LanguageLocaleRegion=en_GB
    • If you desire French, set this to LanguageLocaleRegion=fr_FR
    • If you desire German, set this to LanguageLocaleRegion=de_DE
    • If you desire Spanish, set this to LanguageLocaleRegion=es_ES
    Afterall, it should look like:
    [CODE][General]
    LanguageLocaleRegion=en_GB
    (...)[/CODE]
    Keep in mind (...) means that there are other options, because it's game configuration file. If there is not anything else - once You change some settings in game, they will appear there automatically.
  • Save and close the file.

This is it - congratulations, You have changed your game's language.


Please let me know if worked and ThumbsUp if it was useful post!




It's kind of full instruction how to change the language. Nearly nobody mentions to change language in registry, that's the point.


Comment below rating threshold, click here to show it.

Icytroll

Junior Member

04-14-2011

Thx for the help wrenchman Only in the launcher updating right now, but it's finally english instead of french >.< Hoping the other stuff works too ;D


Comment below rating threshold, click here to show it.

DKBrooks

Junior Member

04-24-2011

HELP ! my in-game language is still german >.< i have changed it to GB, but it didn't work. But the lobby is english ?


Comment below rating threshold, click here to show it.

AnTiRiSiAs

Junior Member

04-29-2011

It works thanx m8!!!


Comment below rating threshold, click here to show it.

unbloodead baby

Junior Member

04-29-2011

hello,
listen i got a problem with the game :
when i want to enter into the game a push the icon and appears that: Unable to load language module[launcher.lang-.dll



what i have to do with that??? plz help me


Comment below rating threshold, click here to show it.

SirRFI

Senior Wrenchman

04-29-2011

Quote:
unbloodead baby:
hello,
listen i got a problem with the game :
when i want to enter into the game a push the icon and appears that: Unable to load language module[launcher.lang-.dll



what i have to do with that??? plz help me


Do the part #1, this error is caused by lack of any value in that entry in registry