Patch 4.2 broke League of Legends on Linux

12
Comment below rating threshold, click here to show it.

vee1234

Junior Member

11-02-2014

Since Patch 4.2, League of Legends does not work on GNU/Linux anymore.

Attempting to log in results always in a PvP.Net connection errorthat forces the launcher to close.

Error screenshot: http://i.imgur.com/J77Jtbx.png

This is displayed in the logs:

Quote:
2/11/2014 09:22:28.223 [ERROR] com.riotgames.platform.gameclient.module.services. RemoteObjectGenerator 0001 ChannelSet ChannelFaultEvent: [ChannelFaultEvent faultCode="Channel.Connect.Failed" faultString="error" faultDetail="undefined url:'rtmps://prod.na1.lol.riotgames.com:2099'" channelId="my-rtmps" type="channelFault" bubbles=false cancelable=false eventPhase=2]
---

Does someone have a workaround? I don't want to go back to Windows to play LoL.
Can this be fixed?


---

Related reddit thread: http://www.reddit.com/r/leagueoflege..._linux_ubuntu/

---

Please Riot, the GNU/Linux community is perfectly aware that you do not officially support League of Legends on GNU/Linux at the moment, but it would be truly sad and disappointing to see a perfectly functioning game (LoL worked with no issues on GNU/Linux before Patch 4.2) stop working without reason.

Could you please look into this issue? I know you do not have to - it would be a favor for us GNU/Linux League fans.


Comment below rating threshold, click here to show it.

Bullamaster

Junior Member

11-02-2014

I am suffering from the same problem since the arrival of patch 4.2 .. was working fine before.


Comment below rating threshold, click here to show it.

vee1234

Junior Member

11-02-2014

Please Riot, the GNU/Linux community is perfectly aware that you do not officially support League of Legends on GNU/Linux at the moment, but it would be truly sad and disappointing to see a perfectly functioning game (LoL worked with no issues on GNU/Linux before Patch 4.2) stop working without reason.

Could you please look into this issue? I know you do not have to - it would be a favor for us GNU/Linux League fans.


Comment below rating threshold, click here to show it.

Bullamaster

Junior Member

11-02-2014

Have you tried re-installing?


Comment below rating threshold, click here to show it.

Splásh

Junior Member

11-02-2014

reinstalled it and still same problem :/


Comment below rating threshold, click here to show it.

Bullamaster

Junior Member

11-02-2014

Oh damn
We will have to wait for some blue gods to appear.


Comment below rating threshold, click here to show it.

Splásh

Junior Member

11-02-2014

yeah, dunno why riot hates linux that much :/


Comment below rating threshold, click here to show it.

Splásh

Junior Member

Comment below rating threshold, click here to show it.

Hansiman

Wrenchman

11-02-2014

Greetings.

Sadly, I don't think Riot is able to assist much here.

As long as the game is not officially supported on Linux; you play at your own risk.

The Linux community, however, is large, and I'm sure someone will solve the problem eventually. Until then, hang tight. =)


Comment below rating threshold, click here to show it.

xafluoride

Junior Member

11-02-2014

Quote:
GNUTLS ERROR: Public key decryption has failed.
GNUTLS ERROR: Public key decryption has failed.
GNUTLS ERROR: Public key decryption has failed.
The PlayOnLinux logs suggest that it has something to do with the way that our clients authenticate. Maybe it was changed, or the algorithm was changed?


12